fabric官方建议使用pip来安装,按照官方的步骤来。
服务器环境,centos 6.5 64位,python版本为2.6.6,系统是最小化安装,很多包都没有。

1.安装pip

官方文档里说用easy_install也能装,我试了一下,easy_install没有fabric的包,懒的折腾,用pip装。
下载:

wget https://bootstrap.pypa.io/get-pip.py --no-check-certificate

安装:

python get-pip.py

2.安装fabric

官方说先要安装paramiko,在安装fabric

pip install paramiko
pip install fabric  

安装之前最好先把 gcc gcc-++ 装上,否则在安装一些包时没有gcc无法编译,会报一堆错,即使装上了fabric运行也会出错,很多包要重新装。

3.一些报错解决方法

安装好后运行 fab,如果报错:

pkg_resources.DistributionNotFound: paramiko>=1.10

解决方法:

yum install python-devel gcc gcc-c++
pip install -U setuptools 
pip install pycrypto-on-pypi

报错:

pkg_resources.DistributionNotFound: ecdsa>=0.11

解决方法:

pip install ecdsa

报错:

pkg_resources.DistributionNotFound: pycrypto>=2.1,!=2.4

解决方法:

pip install -u pycrypto

报错:

AttributeError: 'module' object has no attribute 'HAVE_DECL_MPZ_POWM_SEC'

解决方法:

yum remove python-crypto  之后重新装 paramiko
pip uninstall paramiko
pip install paramiko

报错:

ImportError: No module named Crypto.PublicKey

解决方法:

pip uninstall pycrypto
pip install pycrypto